Update on Oovium problems with iOS 4.3

Update on Oovium problems with iOS 4.3

Postby joe » Wed Dec 12, 2012 10:03 am

Ok, first off, Oovium (and all apps released for iOS 6 and the iPhone 5) will simply not work on 1st and 2nd gen devices using the old armv6 chipset. This is the original iPhone and iPhone 3G as well as the 1st and 2nd gen iPod touches.

However, every time one updates an app in iTunes the old version of the IPA gets thrown in the trash. So, potentially, one could find an old version of Oovium and run it on these old devices. I have personally gotten Oovium 1.0.3 to run on the 1st gen devices (original iPhone and iPod Touch); it is a little quirky, but works ok. Oovium 1.1.3.1 seems to work well on 2nd gen devices (iPhone 3G and 2nd gen iPod Touch) running iOS 4.2.1.

For all other devices, Oovium will work fine on iOS 5+.

So, for anyone using a later device, but with an earlier version of iOS there are a few options:
1: Upgrade your OS. All 3rd+ gen iPhones and iPod Touches as well as all iPads can upgrade to at least iOS 5.1.1.
2: Downgrade Oovium to 1.1.3.1. Oovium 1.1.3.1 works at least as far back as iOS 4.2.1.
3: Volunteer to test Oovium 1.1.3.4 on your iOS 4.3 device. I don't have any iOS 4.3 devices available and so I'm hesitant to release the app without testing it on an actual iOS 4.3 device.

Obviously, the compatibility requirements for Oovium 1.1.3.2 and 1.1.3.3 should have been listed as iOS 5+. Going forward, unless I release the 1.1.3.4 version, support for iOS 4.3 will be dropped.

At any rate, if the above was confusing here is a handy table:

(original) iPhone and iPod Touch (1st gen)
chipset: armv6
highest iOS: 3.1.3
Oovium: will not work, however downgraded Oovium 1.0.3 will mostly work. (For some reason screen rotations get stuck, but other than that it seems ok)

iPhone 3G and iPod Touch (2nd gen)
chipset: armv6
highest iOS: 4.2.1
Oovium: will not work, however downgraded Oovium 1.1.3.1 will mostly work. (Annoyingly, the keyboard will popup when the app first launches, but other than that it seems ok. The keyboard is probably related to Oovium testing for the existence of the external keyboard, so I'm guessing downgrading to 1.1.2.4 will eliminate that problem, but than you lose the new 1.1.3 features)

iPad (1st gen) and iPod Touch (3rd gen)
chipset: armv7
highest iOS: 5.1.1
Oovium: works fine, but must upgrade to iOS 5+.

iPhone 3GS, iPhone 4, iPhone 4S, iPod Touch (4th gen), iPod Touch (5th gen), iPad 2,3, iPad Mini
chipset: armv7
highest iOS: 6.0.1
Oovium: works fine, but must upgrade to iOS 5+.

iPhone 5 and iPad 4
chipset: armv7s
highest iOS: 6.0.1
Oovium: works fine.
User avatar
joe
Site Admin
 
Posts: 241
Joined: Thu Jul 16, 2009 3:19 am

Return to Oovium

Who is online

Users browsing this forum: No registered users and 1 guest

cron